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On the Fence? Tried and Gave Up?

Macromedia no longer sells CF Studio
Folded features into Dreamweaver MX

Some have tried it and run away
May have found it performs poorly (can fix)
Or lacks features they expect (most can be found or 
added)

Others may use it and miss out on many features
Very rich environment, many features

Some best suited to designers
Plenty to offer coders and application developers
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Topics

Change Your Perspective: Developer vs 
Designer
Turbo-charge DWMX: Speed Up Tips
Don’t Miss Out on HomeSite+
What’s In/Out of/New in DWMX Compared to 
CF Studio
Learning More
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About Your Presenter

Team Macromedia member
Tech Co-Editor ColdFusion Dev Journal Magazine

Frequent writer for them, Macromedia DevCenter
Macromedia Certified Instructor
Macromedia Certified Advanced CF Developer
Consultant/Trainer/Frequent Speaker to User Group, 
Conferences worldwide
ColdFusion User Group Manager 

Southern MD (PAX)
Based in DC area
Founder/CTO SysteManage
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Change Your Perspective: 
Developer vs Designer

Much of DWMX heritage is for web page 
authors, designers

Many features to help with things we just do by 
hand
Some developers can leverage the tools

But we prefer to work by hand
And don’t want the tool messing with our code!

Just avoid those features, for instance:
Work in “code view” rather than “design view”
Will look at many other features and differences 
later
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Turbo-charge DWMX: Speed up 
Tips

Just starting it can take a long time
45 seconds on one machine, just 15 on another
Still may be too long for many
And many DWMX operations run lots of 
JavaScript under the covers and may seem slow

1st tip: consider faster machine
600 Mhz with 128 meg of Ram just doesn’t cut 
it anymore

Especially if running CFMX, Outlook, Word, etc all 
at once

Things are dramatically faster on a newer 
machine, like a 2Ghz with a Gig of Ram
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Turbo-charge DWMX: Speed up 
Tips (cont.)

2nd tip: Beware “Refresh File List 
Automatically” in Site config

Enabled by default during Site definition
Causes refresh of site file list whenever you 
leave and return to DWMX

HUGE improvement if disabled
If not editing files outside anyway, it’s pointless
Just jumping out for email or browsing becomes 
painful

Set on local, remote, and testing servers
In latter cases if “access” is “local/network”

www.systemanage.com our practice makes you perfect tm 8

Turbo-charge DWMX: Speed up 
Tips (cont.)

3rd tip: Beware “Automatically upload files to server on 
save” in Remote Info tab of Site config

Will obviously be very painful if unexpected
Fortunately, NOT enabled by default during Site 
definition

4th tip: Don’t leave Databases or Components tab open 
on close of DWMX

On restart, will repopulate those, adding to slow 
startup time

Need to really reboot to see this. 
Just closing/re-opening, it seems to cache the data

If testing this, be sure that CFMX is started after reboot
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Turbo-charge DWMX: Speed up 
Tips (cont.)

5th tip: beware very large files with many queries
If a CF file, defined in a site, is opened with the 
“Bindings” tab open

DWMX will create a binding for each query
6th tip: Disable Virus Checking on DWMX folder

Because DWMX runs a lot of JavaScript code, real-
time virus checking can be expensive
Exclude \Program Files\Macromedia\Dreamweaver 
MX\ from virus checker

And Documents and Settings\[username]\Application 
Data\Macromedia\Dreamweaver MX\Configuration

In Norton AV and others, search help for “exclude 
files”
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Turbo-charge DWMX: Speed up 
Tips (cont.)

7th tip: read Tom Muck’s list of configuration tweaks
http://www.dwteam.com/Articles/speedhints/index.asp

8th tip: Apply recent DWMX Updater 
improves speed some (25% in some ops)
http://www.macromedia.com/support/dreamweaver/ts
/documents/updater.htm
Pay attention to install docs!

Disable extensions , backup sites, stop virus checker
Close DWMX before disabling extensions: seems faster
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Turbo-charge DWMX: Speed up 
Tips (continued)

See my upcoming MXInsite article, “Speeding 
Up Dreamweaver MX”
Still: slow wait for components, time to add 
web service
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Don’t Miss Out on Homesite+

Included on DWMX and Studio MX CD
Just not listed on installer menu
Free, legit licensed version for DWMX owners

Is a melding of CF Studio 5 and HomeSite 5
Only thing missing was customizable toolbars 
and resource windows

Due to Adobe lawsuit just before its launch
Updater available to fix that, and many bugs

Get it at 
http://dynamic.macromedia.com/bin/MM/software/
trial/hwswrec.jsp?product=hsp_updater 
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What’s In/Out of DWMX Compared 
to CF Studio

Features Still There
Changes vs. Studio
Features Expanded Versus Studio/HomeSite
Features Lost That Are/Are Not Recoverable
Features Gained Versus Studio
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Features Still There

Tag/function Insight (now called “code hints”)
Tag Editor (ctrl-f5, modify>edit tag)
Tag Help (shift f1)
Tag Chooser (insert>tag or ctrl-e)
Tag Inspector (window>tag inspector)
Snippets (window>snippets)
Toolbars
Syntax Coloring
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Features Still There (cont.)

Database tool (window>databases)
RDS support
Browser preview (file>preview in browser or 
F12)
Internal browser (view>server debug)
Spell checking (text>spell checking)
Link checking (file>check page>check links)
Indent/outdent line (edit menu, same 
shortcuts)
can open CFINCLUDEd files (right click and 
choose “open document”)
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Changes Versus Studio

Tag Help (was f1 on tag, now shift-f1)
Function help not available by default
Note: complete CF help docs available via ctrl-f1

Not context sensitive, but full-sized window

Tag Editor (was ctrl-f4, now ctrl f5)
Hide panels (was f9, now f4)
Could alter these with keyboard shortcut 
changes (edit>keyboard shortcuts)
Replace is now within Find

Extended find/replace also in Edit>Find
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Features Expanded Versus 
Studio/HomeSite

Popup of available names of predefined variables (like 
server., cfhttp., error., etc.) while typing
Snippets: dozens of preconfigured ones

Especially accessibility, form elements>drop downs, 
JavaScript, navigation, headers/footers

Wizards: replaced by server behaviors (window menu)
Also see insert>application objects feature

Find/replace: “find in” and “search for”
Richer help references

HTML, CSS, JavaScript, Accessibility, ASP, JSP, CFML
Select Parent/Child Tag (see Edit menu)
Debugging Panel (view>server debug)
Tag Hints come up immediately 
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Sometimes It’s the Little Things

Try DWMX Search/replace 
Many more options
For example, set “search for” to “specific tag”

Notice all its options to find a specific tag

And it can search across all files
Just as Studio’s “extended find” could

But Studio could search a remote project
DWMX cannot search a remote “site”
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Features Lost That Are 
Recoverable

File Close All, Context-sensitive help for 
functions, Go To Line--available as extensions

http://www.dmxzone.com/ShowDetail.asp?NewsId=1808
http://mythic.com/code/coldfusion/index.html
http://www.dwteam.com/Extensions/Go%20To%20Line%
20Number.mxp

Shortcut for surround with pounds/comments
Use Edit>Keyboard Shortcuts

See Insert>ColdFusion Basic Objects
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Features lost, not recoverable (or 
not easily)

CF code debugger
Query builder (there is one, but not the visual style in 
Studio)
Replace across multiple files doesn’t offer “make 
backups”

But does warn that only open files can be undone
Shortcuts for snippets
Code collapse
Gutter
Source code support other than VSS

But does support use of WEBDAV to connect to 
remote server

some version control systems support WEBDAV, I’m 
told
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Features Gained Versus Studio

Key Features That Don’t Change Code
Key Features That Can (can help) Change 
Code
Key Features That Generate Code
Key Features That Generate HTML
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Just No Time To Detail Them All

Will cover them, and demonstrate them and 
all these mentioned so far, in day-long 
seminar

As well as cover still lots more

But let’s at least list some key features
You can explore them on your own
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Key Features That Don’t Change 
Code

Component/Web Services integration
Listing all components on server
Creating new components (+ in components tab)
Listing all previously visited web services
Adding new web services (+ in web services tab)
Drag and drop creation of calls to components and 
web services

Site Management
remote/testing server
check in-out options

Code Validation (File>Check Page)
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Key Features That Can (can help) 
Change Code

Bindings Panel
Live Data Preview
Templates
HTML Cleanup
Source Formatting
Change Links Sitewide

And by moving files

Design View
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Key Features That Generate Code

Insert>Application Objects 
Recordset, dynamic table (scroll records), 
master/detail pages, insertion/update forms 

Window>Server Behaviors>+ 
Those above and stored procedures, user 
authentication code

Window>Components
Create, use components/web svcs (get details, 
insert code), view all installed components/web 
svcs
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Key Features That Generate HTML

File>New
Page designs, stylesheets, framesets, more 

Snippets
Window>Behaviors>+

Several JavaScript features, form validation, more
Insert>Interactive Images

Flash buttons/text, Rollover images, Nav bar
CSS features
Site Assets
Creating animations with “timeline”
Create Web Photo Album
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Still Not Listing All Useful Features

Will list more, and demonstrate these as well, 
in day-long seminar

May seem a sales pitch or tease
Hope info offered has been helpful

Would certainly welcome any of you coming to 
the seminar
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Learning More

Beware: docs, many books focus on teaching DWMX to 
designers, web page authors
Some recent books do better

Dreamweaver MX: The Missing Manual
Dreamweaver MX: Beginner’s Guide
Macromedia MX eLearning: Advanced Training from 
the Source

Articles on Studio/HomeSite-DWMX Migration
http://www.macromedia.com/support/dreamweaver/
htmljava/migrating_hs_to_dwmx/
http://www.macromedia.com/support/dreamweaver/
programs/migrating_cfs_to_dwmx/
http://www.macromedia.com/desdev/mx/dreamwea
ver/articles/why_migrate.html
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Learning More (cont.)

See the various DesDev articles showing how to use 
DWMX and CF together. There are many, including:

“Creating ColdFusion web service pages with 
Macromedia Dreamweaver MX” 

http://www.macromedia.com/support/dreamweaver/co
ntent/websrv_cf/ 

“Creating a Web Service Application Using 
ColdFusion MX and Dreamweaver MX”

http://www.macromedia.com/desdev/mx/dreamweaver
/articles/webservice.html

CFMX Evaluation/Getting Started Guide
http://www.macromedia.com/software/coldfusion/reso
urces/get_started/zip/CFMX_eval_tutorial.zip

www.systemanage.com our practice makes you perfect tm 30

Learning More (cont.)

See my blog for more tips: cfmxplus.blogspot.com
Also see several related “video tips of the week”

http://www.macromedia.com/desdev/tip/archive.ht
ml, including

Getting Started with Dynamic Pages in Dreamweaver 
MX
Enhanced Code Editor for Dreamweaver MX
Site Definition in Dreamweaver MX
Dynamic Lists in Dreamweaver MX 

Also see training videos at http://www.vtc.com/
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One Day Seminar

Planning one day seminar, “DreamWeaver MX 
For CF/Studio Users”
Much more of these same points:

Transitioning From Studio/HomeSite
Speeding Up DWMX
Annoyances
Tips and Hidden Gems
Useful Extensions
Where to Learn More 
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Charlie Arehart
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